Repo for the search and displace core module including the interface to select files and search and displace operations to run on them. https://searchanddisplace.com
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

30 lines
760 B

{pkgs ? import <nixpkgs> {
inherit system;
}, system ? builtins.currentSystem, noDev ? true}:
with pkgs;
let
composerEnv = import ./composer-env.nix {
inherit (pkgs) stdenv lib writeTextFile fetchurl php unzip phpPackages;
};
phpPack = import ./php-packages.nix {
inherit composerEnv noDev;
inherit (pkgs) fetchurl fetchgit fetchhg fetchsvn;
};
in
stdenv.mkDerivation {
name = "searchanddisplace-core-source";
src = builtins.fetchGit {
url = "https://git.law/newroco/searchanddisplace-core.git";
ref = "master";
};
phases = [ "installPhase" ];
installPhase = ''
cp -r $src $out
cp $out/.env.example $out/.env
cd $out
npm run prod
php artisan key:generate
php artisan migrate
'';
}