Repo for the search and displace ingest module that takes odf, docx and pdf and transforms it into .md to be used with search and displace operations
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 

30 lines
783 B

{pkgs ? import <nixpkgs> {
inherit system;
}, stdenv, system ? builtins.currentSystem, noDev ? true}:
let
composerEnv = import ./composer-env.nix {
inherit (pkgs) stdenv lib writeTextFile fetchurl php unzip phpPackages;
};
phpPack = import ./php-packages.nix {
inherit composerEnv noDev;
inherit (pkgs) fetchurl fetchgit fetchhg fetchsvn;
};
in
stdenv.mkDerivation {
name = "searchanddisplace-ingest-source";
src = builtins.fetchGit {
url = "https://git.law/newroco/searchanddisplace-ingest.git";
ref = "master";
};
phases = [ "installPhase" ];
installPhase = ''
cp -r $src $out
cp $out/.env.example $out/.env
cd $out
php artisan key:generate
php artisan queue:deploy-supervisor
supervisorctl start all
'';
}