Initial repo for search and displace code (written for, rather than the tools used in the processing)
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 

34 lines
1.0 KiB

with import <nixpkgs>{};
{ stdenv, fetchGit, sbcl, unzip, curl, git, openssl, php, phpPackages, nodejs}:
let
name = "search-and-displace";
gitStore = builtins.fetchGit {
url = "https://git.law/newroco/searchanddisplace.git";
ref = "master";
};
inherit (phpPackages) composer;
buildPackage = { name, src }:
stdenv.mkDerivation {
inherit name src;
buildInputs = [ curl git openssl php composer nodejs ];
buildCommand = ''
#cd $src
#composer update
#composer install
#npm install
# cp .env.example .env
mkdir -p $out
cp -R $src/* $out
mv * $out
# Remove unwanted files - that is impossible with, nix, give up...
#rm -f $out/*.nix
#rm -R $out/pkgs
# Remove stuff not needed on production - composer.lock, composer.json, etc, etc - that is impossible with, nix, give up...
'';
};
in
buildPackage {
inherit name;
#src = ./.;
src = gitStore;
}